Differences

This shows you the differences between two versions of the page.

Link to this comparison view

aix_packages_old [2013/11/13 20:16] (current)
jim created
Line 1: Line 1:
 +(This is the old version of my AIX Packages page. All packages here are still available, but unless you're stuck with having to use Python 2.3 or Python 2.4 I suggest you head straight back to the current [[aix_packages|AIX Packages]] page.
  
 +====== AIX Packages ======
 +
 +Information on various AIX packages I've made.
 +
 +These packages are provided as a service to the AIX community. I make no claim about their fitness or correctness. The only thing I promise about them is that they will take up space on your hard drive.
 +
 +Some of the packages may require other packages installed; for example, Python requires Tcl and Tk. In all cases the required packages are available from [[http://​www-03.ibm.com/​systems/​p/​os/​aix/​linux/​toolbox/​download.html|IBM]].
 +
 +You can download my packages [[http://​www.lunch.org.uk/​aix/​rpms|here]]. Source RPMSs (SRPMS) are [[http://​www.lunch.org.uk/​aix/​srpms|here]].
 +
 +All packages were built on my AIX 5.2 system. They are only suitable for AIX 5.2 and above. If you have an earlier AIX release, you'll need to use the SRPMS to make suitable binaries.
 +
 +===== Minor utilities =====
 +
 +[[http://​software.frodo.looijaard.name/​getopt/​|getopt]]. Options processing for shell scripts, needed by ''​xmlto''​. The tar file from the main website is broken at present; I got mine from the FreeBSD archive.
 +
 +[[http://​www.mktemp.org|mktemp]]. Safe temporary file creation for shell scripts, also needed by ''​xmlto''​.
 +===== Python =====
 +
 +[[http://​ww.python.org|Python]]. The recently released Mercurial 1.3 now requires at least Python 2.4. Since there is no IBM packaged Python later than 2.3, I've made a Python 2.4 package based on the IBM 2.3 package, incorporating the same fixes and adding some new libraries. Using it, Mercurial 1.4 passes its test suite.
 +
 +13/2/2013. I've just put up Python 2.4.6-2 RPMs. This is build using the AIX system curses library, not ''​ncurses''​. The latter, at least in the IBM RPM, causes a Mercurial 2.5 test failure - setting foreground and background colours doesn'​t work.
 +
 +I have since discovered that later versions of Python are packaged by Michael Perzl at [[http://​www.perzl.org/​aix/​|perzl.org]].
 +
 +IBM package Python 2.3.4. While packaging Mercurial, I traced a failure in the Mercurial test suite (creating a small bzipped tar file) to a Python bug fixed in 2.3.5. The latest in the Python 2.3 series is Python 2.3.6, so I packaged that by updating the IBM source package to 2.3.6.
 +
 +The IBM Python package also has problems with semaphores on AIX 5 systems. I've applied the patch from the [[http://​bugs.python.org/​issue1234|current Python bug report on the issue.]]
 +
 +===== Python add-ons =====
 +
 +[[http://​pypi.python.org/​pypi/​setuptools|python setup tools]]. Python package handling tools.
 +
 +[[http://​pygments.org/​|pygments]]. Python syntax highlighter.
 +
 +[[http://​www.pythonware.com/​products/​pil/​|Python Imaging Library]]. Image processing for Python.
 +
 +[[http://​docutils.sourceforge.net/​|docutils]]. Python documentation utilities.
 +
 +===== Documentation tools =====
 +
 +[[http://​www.methods.co.nz/​asciidoc/​|asciidoc]]. Mercurial used to use AsciiDoc to generate its documentation,​ converting plain text files to man pages and HTML pages using DocBook/​XML. It now uses [[http://​docutils.sourceforge.net/​|docutils]].
 +
 +[[http://​cyberelk.net/​tim/​xmlto/​|xmlto]]. After generating DocBook/XML output, AsciiDoc calls ''​xmlto''​ to convert that output to the desired target format. ''​xmlto''​ requires my ''​getopt''​ and ''​mktemp''​ packages, my DocBook packages and the IBM ''​libxslt''​ package to run.
 +
 +===== DocBook =====
 +
 +[[http://​www.oasis-open.org/​docbook/​|docbookx]]. IBM supply a RPM package of DocBook/XML DTDs, ''​docbookx''​. Unfortunately it is insufficient for my needs, containing only version 4.1.2. I need version 4.2 as well. So I made my own replacement ''​docbookx''​ package containing the DocBook/XML DTDs for versions 4.1.2, 4.2, 4.3, 4.4 and 4.5.
 +
 +[[http://​docbook.sourceforge.net/​projects/​xsl|docbook-xsl]]. These are DocBook/XML XSL stylesheets. It is these stylesheets that are used to translate DocBook/XML input into man page, HTML and other output formats.
 +===== Version control =====
 +
 +[[http://​www.selenic.com/​mercurial|Mercurial]]. The aim of all the above was to package Mercurial, and all the tools needed to build it (including the documentation) on AIX.
 +
 +Note that if you want to install and run Mercurial, you only need the Mercurial package and possibly a Python package from this page. All the other packages are only necessary if you want to be able to rebuild the Python package from source.
 +
 +The latest Mercurial package available is for Mercurial 2.7. This is a stock package - built from the unpatched release sources and packaged into a RPM with ''​contrib/​buildrpm''​ using the standard Mercurial specification,​ now compatible with AIX. The 1.3 and later releases require Python 2.4 or later, so if you install 1.3 or later you may need to also install my Python 2.4 package.
 +
 +Older packages for releases back to 1.0 are also available, all the stock release, except for 1.2 which has a trivial patch to report the version correctly. Finally, the original 0.9.5 release is also available. This has three patches applied. One patch corrects a small error in the patch import code which stops it running under Python 2.3, another fixes an AIX issue in the binary diff C module and the last one fixes hgmerge to insist on the GNU utilities; the default AIX ones are not sufficient. The first two of these patches were accepted into the official 1.0 source, and as to the third, well, hgmerge is no more.
 +
 +For Mercurial releases prior to 1.3, you can use the stock IBM Python 2.3.4 package, but I suggest you consider installing my Python 2.3.6 package. The IBM package is mostly sufficient, and if you need/want to stick with it I don't think you will have any problems. But it does cause a failure in the Mercurial test suite, and may cause error messages about semaphore problems.
 +
 +===== GNU Emacs =====
 +
 +The IBM packages for [[http://​www.gnu.org/​software/​emacs/​|GNU Emacs]] are, at the time of writing, still at version 21.3. This is now an entire major version behind.
 +
 +So I've done a package for Emacs 22.3. I include an update to the old emacs-X11, and a new emacs-motif package, build to use the Motif widgets. I did build the GTK version, but it crashes on startup.
 +
 +The IBM package builds using the IBM compiler. I've switched to gcc after finding that Emacs executables built with xlc crash on startup.
 +
 +emacs-nox (no GUI support), emacs-X11 and emacs-motif are mutually conflicting. Pick just one to install.
 
aix_packages_old.txt ยท Last modified: 2013/11/13 20:16 by jim
chimeric.de = chi`s home Creative Commons License Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0